Results 1 to 6 of 6
  1. #1
    Join Date
    Sep 2017
    Location
    Worldwide
    Posts
    1
    Rep Power
    0

    Default Hi, painfully slow loading site for me

    Hi. I've just joined the forum, but for some reason, I've never encounterd a web site that loaded to slowly. Every time I click something, it takes about a minute and a half to load.

    That said, is this something that anyone else has experienced? And has a solution been found, if so? Needless to say, I won't be hanging around long under that circumstance. I don't have this issue any place else on the Internet. I've experimented with using this site on different browsers, which all resulted in the same behavior.

    Thanks.
    Last edited by Fndersbld; October 1st, 2017 at 10:25 pm.

  2. Sponsored Links


  3. #2
    Join Date
    Sep 2008
    Location
    red PA (not Phila)
    Posts
    38,377
    Rep Power
    19

    Default

    Quote Originally Posted by Fndersbld View Post
    Hi. I've just joined the forum, but for some reason, I've never encounterd a web site that loaded to slowly. Every time I click something, it takes about a minute and a half to load.

    That said, is this something that anyone else has experienced? And has a solution been found, if so? Needless to say, I won't be hanging around long under that circumstance. I don't have this issue any place else on the Internet. I've experimented with using this site on different browsers, which all resulted in the same behavior.

    Thanks.
    Welcome to the forum! Unfortunately the site is frought with bugs and adware and whatever else.

    It sometimes takes me minutes to load the page.

    No one has the smarts or desire to fix them.

    you just kinda have to deal with them if it matters enough to you to point out raging idiocy.

    hopefully you do we could use another thinking man ( or woman).

    Good luck!
    Last edited by ThinkingMan; October 2nd, 2017 at 7:10 am.


  4. Sponsored Links


  5. #3
    Join Date
    Feb 2016
    Location
    Panem
    Age
    20
    Posts
    2,618
    Rep Power
    3

    Default

    Hi Fndersbld,
    Yes, unfortunately the site has been loading slowly. I'm speculating that it's the ads, but don't quote me on that. The animated ads are the really bad ones, because of the animation.

    Anyway, welcome to the forums!
    "Ignis aurum probat"

  6. Sponsored Links


  7. #4
    Join Date
    Jan 2004
    Location
    Indianapolis
    Age
    46
    Posts
    18,917
    Rep Power
    20

    Default

    It seems this section of the forum is cursed. Pretty much every new poster who starts off in here never goes onto be a regular poster. New posters tend to dive straight in.

  8. Sponsored Links


  9. #5

    Default

    Yes, Sloooooow

  10. Sponsored Links


  11. #6
    Join Date
    Sep 2003
    Location
    stagnation
    Posts
    13,871
    Rep Power
    18

    Default

    Once I installed an ad blocker software on my browser it fixed everything.
    Wherever you go, there you are.

  12. Sponsored Links


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •